Cannon D70 video shootings issue

Discussion in 'Tutorials & Tips' started by Maaraac, Nov 25, 2020.

  1. Maaraac

    Maaraac New Member

    Joined:
    Nov 25, 2020
    Messages:
    2
    Equipment:
    Cannon D 70
    Idk if this is the right place to ask those questions. I got a camera from my granddad. It shoots great photos but i have issues with video's. The video's are really noise (bad quality, video is really pixelated) is that because old camera or bad settings?
     

  2. johnsey

    johnsey Site Moderator Staff Member Site Supporter

    Joined:
    Apr 21, 2017
    Messages:
    1,297
    Location:
    Fargo, ND
    Equipment:
    5dMk4, 5dsR, 5dMk2, 20D, 70-200 2.8L IS, 100mm 2.8 Macro USM, 50mm 1.4, 85mm 1.8, 17-40mm 4.0L, TS-E 24mm 3.5L II, Rokinon 14mm 2.8; Pixma Pro-100
    The canon 70d is not that old, my guess is that your using a high ISO for video. ISO is the culprit for digital noise, especially if it is not exposed or lit properly at higher ISO.
     
  3. Maaraac

    Maaraac New Member

    Joined:
    Nov 25, 2020
    Messages:
    2
    Equipment:
    Cannon D 70
    Great thx I am new to camera shooting I'll try that out!
     
  4. Caladina

    Caladina Well-Known Member

    Joined:
    Jan 30, 2020
    Messages:
    1,133
    Equipment:
    Canon M50
    Canon 18-45mm m, Canon 18-150mm m, Canon 55-200mm m, Canon 22mm m, Canon 28mm m macro,
    Sigma 100-400c ef, Sigma 18-35mm art ef,
    7artisans 7.5mm m, Laowa 100mm macro ef, laowa 9mm zeroD m, Vintage M42 Lenses:
    Ashi Super - Takumar 1.8 / 55mm,
    seaching youtube for "70d video settings" brings up a load of vids you might find useful
     
  5. Ellinor William

    Ellinor William New Member

    Joined:
    Oct 18, 2021
    Messages:
    15
    Equipment:
    Canon EOS 90DSLR
    For a smooth video performance. I suggest you should put the Shutter Speed 1/50, Frame Rate 23.98fps, and try to lower the ISO. this will fix the problem.
     

Share This Page