Canon 80D some buttons / auto focus not working in any lense

Discussion in 'Technical Troubleshooting' started by Pablo Casso, Mar 17, 2023.

  1. Pablo Casso

    Pablo Casso New Member

    Mar 17, 2023
    Canon 80D

    I have had this 80D for some time now (used) and it has worked as supposed to. Now I faced a big problem I cannot find the solution. First, the camera has never dropped or damaged in any way, so that s not the case.

    The problem is this:
    1) I noticed that auto focus does not work in any lense. It had worked perfectly before. Manual focusing does work normally.
    2) I cannot change any setting except the default; in AV I can changer F value, in TV I can change shutter speed (by scrolling with right hand finger). But I cannot select any other value to change.
    3) The "shooting button" does not have the right feeling. It is just on / off button. It is kind of lacking the focusing part when pushing softly. But the button is not stuck, I can take photos without AF.

    There is some grey symbol (down on the right side). Kind of square woth a circle inside it. I havenĀ“t noticed that before. Maybe it has something to do with this problem?

    Thanks for your help!


Share This Page