EOS 7D and EOS utility 3

Discussion in 'Canon EOS Digital SLRs' started by Claude Fortier, Mar 10, 2021.

  1. Claude Fortier

    Claude Fortier New Member

    Joined:
    Mar 10, 2021
    Messages:
    10
    Equipment:
    EOS 7D Mounted onto my microscope at the top with T2 adapter to photo tub.
    Is any one familiar with EOS Utility for Canon camera? I've got the old version 2 working, and when I install version 3... it installs, but won't recognize my camera... should I even bother trying to make version 3 work? what advantages will I gain if I do get version 3 working? and if any body is familiar with every thing I just mentioned, I'm using a Canon EOS 7D also I use this on a microscope photo tube so I'm not using any camera lenses
    Thanks folks.
    Claude
    Like


    Comment

    Share
     

  2. johnsey

    johnsey Site Moderator Staff Member Site Supporter

    Joined:
    Apr 21, 2017
    Messages:
    1,184
    Location:
    Fargo, ND
    Equipment:
    5dMk4, 5dMk2, 20D, 70-200 2.8L IS, 100mm 2.8 Macro USM, 50mm 1.4, 85mm 1.8, 17-40mm 4.0L, Rokinon 14mm 2.8; Pixma Pro-100
    Version 2 and 3 are separate installs, they will only recognize the camera they are designed to. So the 7d uses v2. if you had a 5dm4 for example that would use v3.
     
  3. Claude Fortier

    Claude Fortier New Member

    Joined:
    Mar 10, 2021
    Messages:
    10
    Equipment:
    EOS 7D Mounted onto my microscope at the top with T2 adapter to photo tub.
    hum, thanks for the heads up.... this is so dispointing... my camera is listed as a supported model, but yet, it's not recognized...
     
  4. johnsey

    johnsey Site Moderator Staff Member Site Supporter

    Joined:
    Apr 21, 2017
    Messages:
    1,184
    Location:
    Fargo, ND
    Equipment:
    5dMk4, 5dMk2, 20D, 70-200 2.8L IS, 100mm 2.8 Macro USM, 50mm 1.4, 85mm 1.8, 17-40mm 4.0L, Rokinon 14mm 2.8; Pixma Pro-100
    Again you stated that v2 works as it is intended. V3 is not for the 7d i do not see your 7d as a supported model, which camera are you expecting to load on v3? For example 7Dmk2 is supported by the v3. https://hk.canon/en/support/0200593502/1 you can see the list of models here.
    As stated in my first post you can have both versions installed on the system and you will connect to the camera through v2 or v3 depending on camera model. These are identical programs essentially. Cameras 6 or 7 year old will use v2 and the newer ones will load v3. There is not cross camera support for the application versions. V3 does not work with older cameras. Likewise if you have something like the original 5d or an old 20/30d you need to find a download for eos utlity 1. They have not carried forward any backward support for older cameras when they refresh the utility for a newer generation of cameras.
     
    Claude Fortier likes this.
  5. Claude Fortier

    Claude Fortier New Member

    Joined:
    Mar 10, 2021
    Messages:
    10
    Equipment:
    EOS 7D Mounted onto my microscope at the top with T2 adapter to photo tub.
    OMG... my Bad...
    I've looked over many times, and always saw 7D daamn... I see where I got confused in what I read... soon as I saw 7D I stopped, not reealizing the mkii at the end of the line...
     

Share This Page