Canon r5c not working with ef 85mm 1.2 v1 on video mode

Discussion in 'Technical Troubleshooting' started by Erjon Beshiri, Jan 20, 2023.

  1. Erjon Beshiri

    Erjon Beshiri New Member

    Joined:
    Jan 20, 2023
    Messages:
    2
    Equipment:
    Canon r5c, canon rf 24-105 f4, canon ef 85mm f1.2 v1, canon ef 70-200 mm f4.
    Hello everyone, lately i bought the canon r5c and i really wanted to shoot videos with it and 85mm 1.2 lens that i had. When i power the camera on video mode it says : Attached lens not supported by the camera. It will not function. I’ve updated the camera to the latest firmware. If anyone have any idea what can i do please let me know.
     

    Attached Files:


  2. GDN

    GDN Well-Known Member

    Joined:
    Jul 22, 2018
    Messages:
    2,189
    Location:
    South Island, NZ
    Equipment:
    A little Canon stuff
    What happens when you try one of your other EF lens on the camera? Do you get the same error message?

    Also, what EF to R adaptor are you using?

    Gary
     
  3. Erjon Beshiri

    Erjon Beshiri New Member

    Joined:
    Jan 20, 2023
    Messages:
    2
    Equipment:
    Canon r5c, canon rf 24-105 f4, canon ef 85mm f1.2 v1, canon ef 70-200 mm f4.
    I get this error only with this lens, i’m using the canon ef to rf adapter, the $99 one.
     
  4. johnsey

    johnsey Site Moderator Staff Member Site Supporter

    Joined:
    Apr 21, 2017
    Messages:
    2,163
    Location:
    Fargo, ND
    Equipment:
    5dMk4, 5dsR, 5dMk2, 20D, 70-200 2.8L IS, 100mm 2.8 Macro USM, 50mm 1.4, 85mm 1.8, 17-40mm 4.0L, TS-E 24mm 3.5L II, Rokinon 14mm 2.8; Pixma Pro-100
    Double check the contacts are nice and clean, others with the r5 have examples of images shot with the 85 1.2. My guess is the Lens is not being read by the adapter, since other lenses work that implies a dirty contact or something on the lens.
    Is the camera firmware up to date?
     

Share This Page