Which Canon EOS Utility For Both Mark III & Mark IV

Discussion in 'Canon EOS Digital SLRs' started by Thomas Hanser, May 11, 2019.

Tags:
  1. Thomas Hanser

    Thomas Hanser New Member

    Joined:
    May 11, 2019
    Messages:
    1
    Equipment:
    Canon EOS 5D Mark III
    Before I go install the wrong version and have to re-install the correct one, can someone verify that EOS Utility 3 will work with both the Mark IV and the Mark III bodies?

    It's not clear to me on the EOS software web site:

    https://www.usa.canon.com/internet/...O-_-SupportPFLandingGreyBar-_-eos_all#eos-all

    There is a different version of the utility for the Mark III and the Mark IV (v 2.0 & v 3.0) and I want to get the correct one installed.

    Thanks!
     

  2. johnsey

    johnsey Site Moderator Staff Member Site Supporter

    Joined:
    Apr 21, 2017
    Messages:
    316
    Location:
    Fargo, ND
    Equipment:
    5dMk2, 20D, 70-200 2.8 L IS, 100mm 2.8 Macro USM, 50m 1.4, 85mm 1.8, 17-40mm 4.0 L, Rokinon 14mm 2.8; Pixma Pro-100
    You want EOS Utility 3.9.0 for Windows not only is that the one for the newer camera but I double checked the software details and it said it supports the Mark III. Even if it didn't you would have to have the newer one to support the newer camera. Worse case scenario you would have to run both the versions of the utility on your computer to support the older camera models.
     

Share This Page